Issue
- Cooker hood stops during use
Applies to
- Cooker hoods
Resolution
1. Switch off the cooker and the hood, wait 15 minutes and switch the appliance back on.
This should give the hood sufficient time to cool down and reset the appliance.
2. Reduce the number of boiling saucepans.
The appliance is designed to absorb odours, not large amounts of steam.
3. Check if the filters are clean and replace them if necessary.
When the cooker hood is working in recirculation mode, to keep your kitchen smelling fresh it is recommended that you replace the carbon filter every 3 to 4 months, depending on the cooker hood usage and type of cooking (fried, fatty food, steam etc.).
4. Make sure the suction from the hood is sufficient.
- Check if the air is flowing out at the air outlet on the external wall.
- If the re-circulation function is activated, check whether the carbon filters are correctly inserted.
5. Contact an Authorized Service Center.
Cause
- Tripped safety switch
- A large number of boiling saucepans
- Dirty / clogged filters
- The duct to the open air might be clogged or in the wrong size